Facebook is down
Incident Report for Recart
Resolved
This incident has been resolved.
Posted Oct 05, 2021 - 04:54 UTC
Investigating
Facebook is down
Posted Oct 04, 2021 - 15:53 UTC
This incident affected: Dashboard and Messaging.